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    About Maralca DSP ToolboxAbout Maralca DSP ToolboxAbout Maralca DSP ToolboxAbout Maralca DSP Toolbox    

Maralca DSP Toolbox is a software tool for visualizing, analyzing and editing digitally sampled signals. It can 
be used with any sequence of numeric values representing samples taken at a regular interval. DSP Toolbox is 
especially useful for working in a DSP (Digital Signal Processing) environment. DSP Toolbox includes a full-
feature, arbitrary complexity FIR filter design tool based on the Parks and McClellan synthesis algorithm. 

Key features of DSP Toolbox include: 

 Powerful and intuitive signal visualization, filtering and editing 

 Advanced editing tools for signal mixing and modulation 

 Multi-graph view 

 Alignment tool aligns graphs by time or using points you specify 

 Importing and exporting of signal data in many formats 

 Signal generator tool for creating simple or composite signals 

 Integrated FIR filter design tool 

 Frequency domain FFT signal analysis 

 Signal event search tool 

 Playback of audio signals 
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    Getting Started with DSP ToolboxGetting Started with DSP ToolboxGetting Started with DSP ToolboxGetting Started with DSP Toolbox    

This section covers the basics of DSP Toolbox’s features and user interface. More detailed information on 
specific topics can be found in subsequent sections. In this document a topic heading may have one or more 
icons adjacent to the heading. These icons are visual cues for toolbar and menu icons related to the topic. 

Entering Numeric ValuesEntering Numeric ValuesEntering Numeric ValuesEntering Numeric Values    
In various dialogs displayed by the software you can enter numeric values to specify parameters or settings. In 
most cases you can enter values as simple numbers, in scientific notation or using engineering scale suffixes. 
The recognized engineering suffixes are: 

Suffix Implied Scale 
T 1012 
G 109 
M 106 
K 103 
m 10-3 
u 10-6 
n 10-9 
p 10-12 

 

For example, you can enter the value 1,000 as 1000, 1e3 or 1K. 

 

About Graphs and Data FilesAbout Graphs and Data FilesAbout Graphs and Data FilesAbout Graphs and Data Files    
DSP Toolbox graphs are similar to documents for signal data: they contain the signal data, which can be 
viewed, edited and analyzed. You create a new graph by importing signal data from a variety of file types. 
Except for WAV files and DSP Toolbox’s own DTBG file type, signal data files simply contain a sequence of 
values, each value being the signal’s sampled value at a point in time. DTBG files contain signal data in 
addition to metadata that retains your customizations and settings. 

Files that do not contain information about the sample rate are referred to as raw files in this document. You 
can always change the sample rate of any signal graph to whatever sample rate is most appropriate for your 
data. For raw files, the sample rate is by default determined by the file type. For most raw files the sample rate 
is set to DSP Toolbox’s default sample rate, which is initially 8 KHz but can be changed in the program options 
dialog (See The Options Dialog section). For μ-Law and A-Law files the sample rate is set to 8 KHz, even if the 
default rate has been set to another value. For WAV and DTBG files the sample rate is obtained from the file 
itself. 

See The Graph Properties Dialog topic in the Working with Graphs section for more information on setting a 
graph’s sample rate. See the Importing Signal Data section for more in formation on sample rates and how to 
create a new graph from a signal data file. 

Graphs are also used to display filter responses and frequency domain spectrums in DSP Toolbox. These 
analysis graphs can be manipulated with the same interaction methods used for signal graphs. 

Graphs can be plotted using one of three plotting methods: using line segments, with curve fitting or as a 
sequence of dots. By default, graphs are plotted using line segments, joining the signal data points with straight 
lines. When plotting with curve fitting, a smooth curve joins all data points, however this plotting method is 
susceptible to distortion and the visual representation may not precisely match the actual data. In particular, 
abrupt transitions can cause overshoot of the fitted curve. The dot plotting mode provides the most basic data 
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representation, with each data point plotted as a small square. This plotting method is useful when you want to 
easily locate individual data points. The plotting method can be changed from the The Graph Properties Dialog. 

Creating and Opening GraphsCreating and Opening GraphsCreating and Opening GraphsCreating and Opening Graphs    
There are several ways to create a new signal graph: 

� From the File menu Open or New selections 
� By dragging a recognized file type into DSP Toolbox’s window 
� By creating a new graph from a section of another graph’s data 

 
DSP Toolbox automatically recognizes these file types: 

dtbg: DTBG files are DSP Toolbox native graph files with embedded graph properties and settings 
alaw: Files with the alaw extension are treated as A-Law compressed audio files 
ulaw: Files with the ulaw extension are treated as μ-Law compressed audio files 
wav: WAV files are standard audio files widely used on PCs 
txt: Text files are parsed for numeric strings defining the sample values 
csv: DSP Toolbox treats CSV files just like text files 

 
See the previous topic, About Graphs and Data Files, and the Importing Signal Data section for more 
information on file types and data formats. 

MultiMultiMultiMulti----Graph User InterfaceGraph User InterfaceGraph User InterfaceGraph User Interface    
DSP Toolbox lets you work with more the one graph at a time. When you invoke an edit or other graph action, 
that action is targeted to the currently selected graph. The currently selected graph is the graph with the blue 
border; unselected graphs have gray borders. For example, in the diagram below only the bottom graph is 
selected. Clicking a graph’s left border selects it and automatically unselects any other graph. Some graph 
actions can be targeted to multiple graphs, and you can select multiple graphs when applying these actions. 
Actions that can be applied to a single graph only will have their toolbar button and menu items disabled if 
more than one graph is selected. See the Working with Graphs section for more information on action targeting 
and working with multiple graphs. 
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The The The The Graph ToolbarGraph ToolbarGraph ToolbarGraph Toolbar    
The graph toolbar along the top of the application window has buttons for each graph action. Each button 
dims when its action is unavailable in the current state or context. Like the Graph menu, the graph toolbar 
operates on all selected graphs. 

The The The The Data ToolbarData ToolbarData ToolbarData Toolbar    
The data toolbar has additional actions that can be applied to a graph’s data or a group of graphs. It includes 
buttons for graph alignment, spectrum analysis, filtering, searching, and audio playback. The Tools menu also 
has these actions. 

The The The The Graph WindowGraph WindowGraph WindowGraph Window                            
The graph window below the two toolbars provides a view of the graphs. You can reorder the graphs by 
dragging them by their left border to a new vertical location in the window. You can resize a graph vertically by 
dragging its top or bottom borders. 

Graphs can be manipulated and edited in many different ways. The Graph, Edit and Tools menus have all of 
the actions available for a graph. You can also use the graph toolbar to perform many of the same actions. 
These menus and the graph toolbar always act on the selected graphs, and you can right-click a graph to get a 
context menu identical to the Graph menu. The right-click context menu always acts on the single graph you 
right-clicked. Many actions have keyboard shortcuts; see the Keyboard Shortcuts section for a complete list of 
shortcuts. 
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Zooming and Zooming and Zooming and Zooming and ScrollinScrollinScrollinScrollingggg                                
In DSP Toolbox a graph’s zoom setting applies only to its horizontal size. (See the Vertical Ranges topic in this 
section for information on how to zoom vertically.) The zoom setting is a number representing the ratio of the 
graph’s width to the window width. For example, if the zoom setting is 2.0, the graph’s width will always be 
twice the window width. The zoom setting does not change as the window is resized, so the graph’s width will 
always be the same relative to the window width. See the Zooming and Scrolling topic in the Working with 

Graphs section for more information. 

Scroll bars appear when any graph is zoomed or there are too many graphs to fit in the window. Horizontal 
scrolling can be accomplished either with the horizontal scroll bar or with the left and right arrow keys. Mouse 
wheel scrolling is supported both vertically and horizontally. Hold down the shift key to scroll horizontally 
with the mouse wheel. 

The Graph CursorThe Graph CursorThe Graph CursorThe Graph Cursor        
Whenever the mouse cursor is inside a graph’s plot area the graph cursor line is visible and a cursor panel 
appears at the bottom of the graph. The cursor panel shows the horizontal location of the graph cursor in the 
graph’s time units and the nearest data point value at that location. 

The Graph MarkerThe Graph MarkerThe Graph MarkerThe Graph Marker                
A vertical red marker line can be placed on the graph that remains fixed until you move it to a new location. 
The marker can be placed with the toggle marker action from the Graph menu or the graph toolbar. You can 
also place the marker with the mouse by Ctrl-clicking on the graph plot area. The marker can be moved by 
dragging it or Ctrl-clicking at a new location. A marker panel appears at the bottom of the graph whenever the 
graph’s marker is set. The panel shows the time location of the marker, the value of the nearest data point at 
the marker’s location and the relative distance between the marker and the cursor. Markers can be used in a 
variety of ways: 

� To measure time relative to the cursor 
� To mark where to insert data when pasting from the clipboard 
� To locate an event when searching 
� To mark the starting point for audio playback 
� To mark a location in a graph that can be quickly returned to 
� To zoom horizontally about the marker location 

 

The Audio Playback ToolThe Audio Playback ToolThe Audio Playback ToolThe Audio Playback Tool            
You can use the audio playback tool to listen to audio signals. This tool is controlled by the last two buttons on 
the data toolbar. The left button of this pair starts and stops audio playback. You can set the audio playback 
sample rate independently of the graph’s sample rate using the drop-down sample rate button on the right. 
Complete information for using the audio playback tool is located in the Playing Audio topic of the Working 

with Graphs section. 

Changing Graph SettingsChanging Graph SettingsChanging Graph SettingsChanging Graph Settings            
You can view and edit many graph settings and customize it to display the signal data in a way that is most 
meaningful to you. The graph properties dialog lets you set many properties, including: 

� Colors 
� Fonts 
� Plot style 
� Graph name 
� Axis units, scaling and offsets 

 
See The Graph Properties Dialog topic in the Working with Graphs section for more information on viewing and 
setting graph properties. 
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The Search ToolThe Search ToolThe Search ToolThe Search Tool            
DSP Toolbox has a search tool for finding events occurring in the signal data based on search criteria you 
specify. An event is a transition through a specified signal level threshold and remaining above or below the 
threshold for a specified minimum duration. See the Searching for Events topic of the Working with Graphs 
section for more information on using the search tool. 

Selecting Selecting Selecting Selecting Signal Signal Signal Signal DataDataDataData            
You can select a section of signal data by dragging horizontally in a graph’s plot area. A selection can be 
adjusted after it is created by shift-clicking either outside the selection to extend it or inside the selection to 
reduce it. You can also adjust the selection range with a shift-click-hold-and-drag mouse gesture. To clear a 
selection, press the Esc key or just click anywhere within the graph’s plot area. 

Data selections are used to target an action to a specific section of data. Some actions, like audio playback, will 
target the entire graph if a selection is not set. Whenever a selection is set in a graph a selection panel appears 
at the bottom of the graph showing the selection’s time range. See the Selecting Data topic of the Working with 

Graphs section for more information on selecting data. 

Editing Signal DataEditing Signal DataEditing Signal DataEditing Signal Data                                
Signal data can be modified by copying, deleting, cutting and pasting data selections. There is also a tool to 
scale a data selection and a FIR filter tool to apply filtering to a data selection. Most editing actions are applied 
to data selections, but the data scaling and filtering tools will act on the entire graph if a selection is not set. 
When pasting data, data from the clipboard replaces the selection if one is set; otherwise the data is inserted at 
the marker location if a marker is set. Edit actions can be undone and redone with the multi-level Undo and 
Redo actions. The basic editing actions are available from the Edit menu and the graph toolbar. The filtering 
and scaling tools are available in the Tools menu and the data toolbar. See the Editing and Filtering topics in 
the Working with Graphs section for more information. 

Vertical RangesVertical RangesVertical RangesVertical Ranges                        
If you drag vertically in a graph’s plot area a vertical range is created. Vertical ranges can be used to zoom 
vertically a section of the graph without changing the graph’s height. Whenever a vertical range is selected a 
range panel appears at the bottom of the graph. The range panel shows the signal value at the top and bottom 
of the range. 

A vertical range can be adjusted after it is created by shift-clicking either outside the range to extend it or 
inside the range to reduce it. You can also adjust the range with a shift-click-hold-and-drag mouse gesture. To 
clear a vertical range, press the Esc key or just click anywhere within the graph’s plot area. 

See the Adjusting the Vertical Range topic in the Working with Graphs section for more information. 

Signal Generator ToolSignal Generator ToolSignal Generator ToolSignal Generator Tool        
The signal generator tool creates sampled signal data for constant (DC), sine, triangle, and pulse waveforms. 
The signal generator can also produce a white noise signal. The signal frequency, amplitude, offset and phase 
parameters are all adjustable. The generated signal can be inserted into a graph, replace existing data, 
arithmetically added to exiting data or modulate existing data by multiplication. The Signal Generator Tool 
topic has complete information on how to create signals with this tool. 

FIR FIR FIR FIR Filter ToolsFilter ToolsFilter ToolsFilter Tools                    
FIR (Finite Impulse Response) filters are a common type of digital filter that can be represented by a set of 
numeric filter coefficients. In general, almost any type of filter can be realized as a FIR filter given a sufficient 
number of coefficients. FIR filter theory is not covered in this document and there are many books and other 
technical resources on FIR filter theory which you can refer to. However, with DSP Toolbox you can easily 
design and apply FIR filters with no prior knowledge of FIR filter theory. 
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DSP Toolbox has several FIR filter tools to help you create and use FIR filters: 

� A FIR filter design tool based on the Parks and McClellan synthesis algorithm 
� A signal editing tool to apply filtering to a section of graph data 
� A FIR filter response visualization tool that shows a filter’s frequency domain response 
� A FIR filter coefficient import and editing tool 

 
You can use the filter design tool to create a set of filter coefficients based on filter parameters you specify. The 
filter coefficients created by the filter design tool can be used directly by the DSP Toolbox filtering tool, saved 
to a file, or copied to the clipboard for use in other software applications. You can also import FIR filter 
coefficients from a file or the clipboard for use in DSP Toolbox. Once you have FIR filter coefficients, either 
from the filter design tool or imported externally, you can apply the filter to signal data in graphs. The filter 
design tool has an integrated filter response visualizer, but DSP Toolbox can display the frequency response of 
any coefficients you import. 

The Filter Design Tool section has complete information on how to use the filter design tool. Information on 
applying filters to graph data and details for the other FIR filter tools is in the Filtering topic of the Working 

with Graphs section. 

FFT Spectrum Analysis ToolFFT Spectrum Analysis ToolFFT Spectrum Analysis ToolFFT Spectrum Analysis Tool        
DSP Toolbox has a spectrum analysis tool to perform an FFT transform on a data selection and display the data 
selection’s frequency domain power spectrum. The spectrum analysis tool can use any selection length and is 
not limited to lengths that are powers of two. If a selection is not set, the tool will produce the power spectrum 
for the entire graph. Several different windowing functions are available to choose from. See The Spectrum 

Analysis Tool section for more information. 

MultiMultiMultiMulti----Graph GroupGraph GroupGraph GroupGraph Groupssss                
Multiple graphs can be selected using the usual shift-click or ctrl-click selection paradigm by clicking in the 
graph’s left border. Actions applied from the Graph menu or the graph toolbar target all selected graphs. Some 
actions can be applied to a single graph only and some can be applied to one or more graphs. If you have more 
than one graph selected and an action is not available, it may be because that action is not available for 
multiple graphs. 

Multiple graphs can be linked together and aligned. Graphs can be aligned automatically by time or manually 
by marker. To create an aligned graph group, select two or more graphs and apply the align by time action 
either from the data toolbar or the Tools menu. You can also align by marker location if all selected graphs 
have their marker set. After alignment, the graphs in the alignment group will show a link icon in their left 
border. All graphs in the alignment group must have the same sample rate. See the Graph Alignment topic in 
the Working with Multiple Graphs section for information on aligned graph groups. 

Printing and Print PreviewPrinting and Print PreviewPrinting and Print PreviewPrinting and Print Preview                
DSP Toolbox provides flexible printing options, giving you the freedom to print graphs in the format and style 
that best meets your needs. Print options are available to choose the graphs’ view, size and page composition. 
See The Print and Print Preview Dialogs section for information on using the print and print preview dialogs. 
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    Importing Importing Importing Importing SignalSignalSignalSignal Data Data Data Data    

There are several ways to open a graph from a data file: 

� Importing with File->New: This menu selection opens a sub-menu of choices for importing signal data into 
a new graph. There is also a menu selection for creating a new empty graph. From the file open dialog that 
appears you can select one or more files to open in the chosen data format. Selecting multiple files allows 
you to easily open several graphs at one time. From File->New you can import a signal from any of these 
file types: 

� WAV audio files 
� Binary files of  8, 16, or 32-bit integers, either signed or unsigned 
� Binary files of 32 or 64-bit IEEE standard floating point values 
� μ-Law or A-Law encoded files 
� Text files in CSV or free-form format 

 
� Importing with File->Open: This menu choice shows a file-open dialog from where you can open DTBG, 

WAV, TXT and CSV files directly. You can select one or more files to open simultaneously. The keyboard 
shortcut for this action is Ctrl-O. 

� From the recent file list: You can reopen files you recently opened from the File->Recent Files menu. 

� Dragging into the DSP Toolbox window: Dragging a DTBG, WAV, TXT, CSV, ALAW or ULAW file into 
DSP Toolbox’s main window will open the file in a new graph. 

Binary File FormatBinary File FormatBinary File FormatBinary File Formatssss    
Binary files are simply sequences of binary values in a particular format without any header data in the file. For 
floating point formats, only finite values are allowed (no infinities, NaNs, etc.) All values must be in little-
endian byte order; the usual byte order for Windows PCs. 

µ----Law and ALaw and ALaw and ALaw and A----Law filesLaw filesLaw filesLaw files    
μ-Law and A-Law are compressed audio formats commonly used for telephony speech signals. In these formats 
each sample is one byte long. DSP Toolbox automatically converts the sample data to 64-bit floating point 
representation when importing from these formats. 

Text File FormatText File FormatText File FormatText File Formatssss    
DSP Toolbox imports signals from text files by parsing the file for numeric character strings separated by one 
or more separator characters. The text file must use the 8-bit ANSI character set (also known as ASCII). The 
recognized separator characters are: 

� Spaces (hex 20) 
� Tabs (hex 09) 
� New line characters (hex 0A) 
� Carriage return characters (hex 0D) 
� Commas (hex 2C) 

 
Each data value must be separated from the next by one or more separator characters. Each data value can be 
an integer or floating point number with an optional + or - sign. Floating point values can include an optional 
signed or unsigned exponent. All values are converted to 64-bit floating point quantities internally by DSP 
Toolbox regardless of the format used. 

The text file may also contain comment lines which are ignored. Any line starting with a /, # or * character is 
treated as a comment. The comment extends to the next new line or carriage return character. 
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About Sample Rates and Time ScalesAbout Sample Rates and Time ScalesAbout Sample Rates and Time ScalesAbout Sample Rates and Time Scales    
When a signal data file is opened the graph’s sample rate is set according to the file type: 

� For DTBG and WAV files the sample rate is obtained from the file itself 
� For μ-Law and A-Law files the sample rate is set to 8 KHz 
� For all other file types the sample rate is set to the default sample rate 

 
The default sample rate is initially 8 KHz but can be set to any desired value in the Graphs tab of the program 
options dialog. The program options dialog is opened from the Tools menu. The sample rate can be set 
explicitly for any graph from the graph properties dialog by setting the horizontal axis’s sample rate property. 
See The Graph Properties Dialog topic of the Working with Graphs section for more information on the graph 
properties dialog. 

The audio playback tool can play the signal data as audio through your computer’s sound system. The sample 
rate for audio playback is initially set to match the graph’s sample rate, if possible. The choice of available 
sample rates for audio playback may be limited by your computer’s audio hardware. You can set the audio 
playback rate independently of the graph’s sample rate by choosing another sample rate from the audio sample 
rate drop-down list. See the Playing Audio topic of the Working with Graphs section for more information on 
the audio playback tool. 
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    Saving Graphs and Exporting Signal DataSaving Graphs and Exporting Signal DataSaving Graphs and Exporting Signal DataSaving Graphs and Exporting Signal Data    

Saving a graph lets you to preserve signal data changes you may have made by editing or filtering the data. Any 
graph properties you changed will also be preserved if you save to the DTBG file type. Saving can also be used 
to change from one file format to another. Here are the different ways you can save signal data: 

� With File->Save: This menu choice is available whenever the graph you are saving was created from a file 
and subsequently modified. The signal data is saved back to the same file it was loaded from. If the graph 
is being saved to a DTBG file then any graph property changes you made will be retained. If you want to 
keep your graph property changes but the source file was not a DTBG file, use File->Save As and choose 
the DTBG file type. The Save menu action can be applied to either a single graph or multiple graphs. The 
keyboard shortcut for this action is Ctrl-S. 

� With File->Save As: This menu choice allows saving the graph as a DTBG, WAV, TXT, CSV, ALAW or 
ULAW file. You can use Save As to change to another file type or to save changes to a different file. Any 
graph property changes you made will be preserved if you save as a DTBG file, otherwise property changes 
will be lost. Use caution when saving to a file type with a smaller data type than the original source file: 
you will overflow the destination file’s data range if the source file has values outside the data range of the 
destination file. 

� With File->Export Graph Data: This menu choice is provided primarily for saving to raw binary files, but 
you can save to other file types as well from here. You can also use this menu choice to save to a DTBG file 
with a particular data type. For DTBG files and raw binary files, you can choose a binary data format or μ-
Law or A-Law. WAV files are always saved in signed 16-bit format. Use caution when exporting to a file 
type with a smaller data type than the original source file: you will overflow the destination file’s data 
range if the source file has values outside the data range of the destination file. 

� With File->Export Data Selection: This menu choice is available whenever a data selection exists in the 
currently selected graph. It is similar to the Export Graph Data file menu choice but only the selected data 
is written to the file. 

About DTBG File Data TypesAbout DTBG File Data TypesAbout DTBG File Data TypesAbout DTBG File Data Types    
Unlike other file types, the signal data of a DTBG file can be in any of the supported data formats. When saving 
a graph that was opened from a raw data file as a DTBG file, the DTBG file’s signal data will have the same data 
types as the source file. You can change the DTBG file’s data type by using the File->Save As menu action. 

SaviSaviSaviSaving and Exporting with Data Scalingng and Exporting with Data Scalingng and Exporting with Data Scalingng and Exporting with Data Scaling    
When saving or exporting to file types other than DTBG, DSP Toolbox can save the signal data with or without 
applying the vertical axis scaling and offset properties. Initially the default is to not apply scaling and offset but 
you can change this in the Graph tab of the options dialog. When this option is set the saved signal data will be 
subject to the vertical axis scaling and offset graph properties. If you use this option, you might loose signal 
precision or overflow the data range depending on the data type you are saving to. This option is ignored for 
DTBG files since the scaling and offset properties are saved in the file separately from the signal data. 
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    Working wWorking wWorking wWorking with Graphsith Graphsith Graphsith Graphs    

This section describes DSP Toolbox graphs and how to change their appearance or edit their data. Actions are 
available from the Graph menu, the graph toolbar or when you right-click a graph. Additional actions are 
available from the Tools menu or the data toolbar. Actions that affect all graphs appear in the View menu or 
the graph toolbar. Wherever an icon is associated with an action, that icon appears next to the action’s 
description. 

The Graph WindowThe Graph WindowThe Graph WindowThe Graph Window    
The graph window is where you view the graphs you have opened or created. You interact with graphs in the 
following ways: 

o Selecting graphs: A graph must be selected before any actions can be applied to it. When a graph is 
selected its border will be blue. You select a graph by clicking the graph’s left border or anywhere outside 
the graph’s plot area. You can also change the current graph selection using the up and down arrow keys. 

You can select multiple graphs by either Shift-clicking or Ctrl-clicking in the usual way. The Ctrl-A 
keyboard shortcut selects all graphs. In this section only single graph actions will be covered; see the 
Working with Multiple Graphs section for information on applying actions to multiple graphs. 

 Create a new graph from a data selection: You can create a new graph from a portion of another graph’s 
data by invoking the New Graph from Selection action. A new graph containing only the selected signal 
data will be opened in the graph window. 

 Closing a graph: Use the Close action to remove a graph from the window. 

 Closing all graphs: The Close All Graphs action removes all graphs from the window. 

 Refreshing a graph from file: The Refresh action reloads the graph’s data from its source file. The keyboard 
shortcut for this action is F5. 

 Refresh all graphs from file: The Refresh All Graphs action reloads all graphs’ data from their source files. 

 Fitting a graph to fill the window height: The Set Height to Fit Window action sets the graph’s height to 
match the window height. 

 Reset all graphs’ zoom to 1: The Reset Zoom of All Graphs action resets the zoom of all graphs to 1. This 
has the effect of fitting all graphs in the window and removing the horizontal scroll bar. The keyboard 
shortcut for this action is Ctrl-1 (Ctrl and the digit 1). 

 Fit to window height: The Set Height of All Graphs to Fill Window action adjusts the height of every graph 
so the window will be filled and all graphs fit vertically within the current window size. There is a 
minimum allowed graph height and this action can only resize graphs down to their minimum height. If 
all graphs will not fit vertically in the window with their heights set to the minimum then the vertical scroll 
bar will still appear. The keyboard shortcut for this action is Ctrl-W. 

Reordering GraphsReordering GraphsReordering GraphsReordering Graphs    
o Graphs can be reordered in the graph window by dragging a graph by its left border and dropping it at a 

new location. As you drag the mouse cursor between two graphs, or to the space just above the top graph, 
the mouse cursor will change to a graph icon and the gap will be highlighted. This is a visual cue indicating 
the graph can be dropped at this location. 

Resizing Resizing Resizing Resizing GraphsGraphsGraphsGraphs    
o A graph’s height can be changed by dragging its top or bottom border. Place the mouse cursor over the top 

or bottom border and the mouse cursor changes to a vertical resize cursor. Click and drag the border to 
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change the graph’s height. The graph’s border will change to a red line while you drag it. You can drag the 
border beyond the boundaries of the window when increasing the height. 

o You can also change a graph’s width in a similar manner by dragging its right border, thereby changing the 
graph’s zoom factor. 

o The default height of a newly opened graph can be set in the Graph tab of the options dialog. 

The Graph Cursor and MarkerThe Graph Cursor and MarkerThe Graph Cursor and MarkerThe Graph Cursor and Marker    
o The graph cursor: The graph cursor is a vertical dashed line that follows the mouse cursor as it moves 

across the plot area. When the graph cursor is visible the cursor panel appears at the bottom of the graph. 
The cursor panel displays the cursor’s position along the horizontal time axis and the signal data value 
closest to the cursor’s location. If you have a marker set in the graph, the marker panel will indicate the 
separation in time between the cursor and the marker. 

 Placing and removing the marker: The Toggle Marker action toggles the graph’s marker on and off. 
Alternatively, the marker can be set at the mouse cursor’s location by Ctrl-clicking anywhere in the plot 
area of the graph. You can remove the marker by toggling it off or by dragging it off the graph. 

o Moving the marker: The marker can be dragged to move it within the graph’s plot area. Place the mouse 
cursor over the marker line in the plot area or the marker’s arrow head in the horizontal scale and the 
mouse cursor changes to a horizontal drag icon, then click and drag the marker to a new location. You can 
also place or move the marker by Ctrl-clicking in the plot area. 

 Bring the marker into view: Use the Go to Marker action to automatically scroll the marker into view. The 
keyboard shortcut for this action is Ctrl-G. 

Selecting DataSelecting DataSelecting DataSelecting Data    
You can select a data range in a graph by dragging horizontally in the graph’s plot area, creating a highlighted 
area on the graph. (If you see blue horizontal lines instead of a horizontal data selection, your drag movement 
was more vertical than horizontal.) You can clear a selection with the Esc key or by simply clicking anywhere in 
the graph’s plot area. You can use any of the following mouse gestures to adjust the selection range after it is 
created: 

� Shift-click to the left of the selection to extend it left to where you clicked 
� Shift-click to the right of the selection to extend it right to where you clicked 
� Shift-click within the selection to move the right selection edge to where you clicked 
� Shift-click and drag outside the selection to move the right or left edge to a new location 

 
You can select all graph data with the Select All action from the Edit menu or using the Ctrl-A keyboard 
shortcut. 
Data selections are used for many different purposes, including: Copying, cutting, pasting and other editing 
actions; exporting the selected data; zooming about the selected area; and exporting the selected data to a file. 

ZoomingZoomingZoomingZooming    andandandand    ScrollingScrollingScrollingScrolling    
A graph’s zoom factor is a number that represents the ratio of a graph’s width to the window width. The zoom 
factor is unaffected when the window width changes, so the ratio remains unchanged. By default the zoom 
factor applies to all graphs and therefore all graphs will have the same width. You can change this default 
behavior in the Graph tab of the options dialog so zoom factors can be set independently for each graph. When 
independent zoom factors are being used each graph can have different widths. 

 Zooming in: The zoom factor can be increased with the Zoom In action. By default the zoom factor is 
doubled each time this action is applied. You can change the zoom step multiplier in the Graph tab of the 
options dialog. The keyboard shortcuts for zooming in are the ‘+’ and ‘=’ keys. 
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 Zooming out: The zoom factor can be decreased with the Zoom Out action. By default the zoom factor is 
halved each time this action is applied. You can change the zoom step multiplier in the Graph tab of the 
options dialog. The keyboard shortcut for zooming out is the ‘-’ key. 

 Zooming about the marker: The Zoom In About Marker action increases the zoom factor to the next level 
and adjust the view so the marker is centered horizontally in the view. The keyboard shortcut for this 
action is Ctrl-M. 

 Zooming the selection: The Zoom Selection action sets the graph’s zoom factor so the selected section fills 
the width of the window. The keyboard shortcut for this action is F9. 

 Setting the zoom factor: You can explicitly set the zoom factor to a particular value from the Set Zoom 
drop-list. The list has fixed zoom selections of 1, 2, and 4, and you can also enter any desired value in the 
list’s edit box. 

o Horizontal scrolling: Whenever a graph’s zoom factor is greater than 1 its width will exceed the window 
width and a horizontal scroll bar will appear along the bottom of the graph window. A red arrow head will 
appear at either or both ends of the graph’s bottom edge as a visual cue indicating the view is incomplete 
and can be scrolled in the indicated direction by dragging the scroll bar. Alternatively, the left and right 
arrow keys can be used to scroll horizontally. The mouse wheel can also be used to scroll horizontally if 
you hold down the shift key while turning the mouse wheel. The Home key will scroll to the left edge of 
the graph and the End key will scroll to the right edge of the graph. 

o Vertical scrolling: If the total height of all graphs exceeds the window height a vertical scroll bar will 
appear along the right edge of the window. The mouse wheel can be used to scroll vertically as an 
alternative to moving the scroll bar. If a graph’s top or bottom extends outside the window a red arrow 
head will appear at either or both the top and bottom of the graph’s left edge, providing a visual cue that 
the graph extends beyond the window edge and can be scrolled in the indicated direction. 

Adjusting the Vertical RangeAdjusting the Vertical RangeAdjusting the Vertical RangeAdjusting the Vertical Range    
When a graph is first opened the vertical axis is automatically adjusted to encompass the full range of values in 
the signal data. The visible range of data values can be adjusted to effectively apply a vertical zoom using the 
range adjustment actions. Whenever a graph’s data range exceeds the height of the vertical axis a small pink 
arrow head appears at the top, bottom or both ends of the vertical axis. This provides a visual cue that the data 
range has been truncated in the indicated direction. 

 Setting the vertical range: To set the vertical range you first create a range by dragging the mouse cursor 
vertically in the graph’s plot area. Two horizontal blue lines will appear marking the start and end where 
you dragged. A range panel showing the vertical extent of the range appears at the bottom of the graph 
when a range is selected. Once a range has been created you can apply the Set Range action to set the 
vertical axis to match the range you created. The vertical axis will then cover the range you selected. 

You can clear the range lines with the Esc key or by simply clicking anywhere in the graph’s plot area. You 
can use any of the following mouse gestures to adjust the range after it is created: 

� Shift-click above the top range line to move it up to where you clicked 
� Shift-click below the bottom range line to move it down to where you clicked 
� Shift-click between the two range lines to raise the lower range to where you clicked 
� Shift-click and drag outside the range to move the top or bottom edge to a new location 

 

 Reducing the vertical range: Reducing the vertical range effectively zooms in vertically on the signal data 
without affecting the graph’s height. Use the Decrease Range action to decrease the vertical range by 
steps. The default step size multiplies the current rage by 1/1.5 (0.667), but you can change the range step 
multiplier from the Graph tab of the options dialog. The range is reduced about its center; if you want to 
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zoom in on a vertical section not centered about the middle of the vertical axis, use the Set Range action 
described above. The keyboard shortcut for this action is Ctrl- - (Ctrl and the hyphen or minus key). 

 Increasing the vertical range: Increasing the vertical range effectively zooms out vertically on the signal 
data without affecting the graph’s height. Use the Increase Range action to increase the vertical range by 
steps. The default step size multiplies the current rage by 1.5, but you can change the range step multiplier 
from the Graph tab of the options dialog. The keyboard shortcut for this action is Ctrl-+ (Ctrl and the plus 
key). 

 Normalizing the vertical range: Use the Auto Range action to automatically adjust the graph’s vertical axis 
so it covers the entire range of signal data values. This action restores the graph’s vertical range to its 
default state. The keyboard shortcut for this action is Ctrl-R. 

The Graph Properties DialogThe Graph Properties DialogThe Graph Properties DialogThe Graph Properties Dialog    

 From the graph properties dialog you can view information about the graph and edit many of its 
properties. The main section of the dialog is divided into two tabs, one for the horizontal axis and another 
for the vertical axis. This topic provides detailed descriptions for each of the properties in this dialog. The 
keyboard shortcut for opening the graph properties dialog is F2. 

� Graph Name: The graph’s name appears in the lower right corner of the graph and can be edited to any 
name you wish. 

� Style: The graph’s plotting style can be selected from this drop-list. Available choices are curve, line 
segments or dots. Choosing Curve results in a smooth plot that uses curve fitting when plotting. This 
choice provides the smoothest graphs but is susceptible to overshooting the actual data points in some 
cases. The Line Segments choice joins the data points with straight line segments. The Dots selection 
plots each point as a small square point on the graph. 

� Trace Color: The trace color is the color used to plot the graph’s data. Clicking the down-arrow button 
to the left of this property will open a color picker dialog where you can choose any color you wish for 
the graph’s plot. When choosing a plot color, keep in mind that the selection and range line colors are 
fixed in the options dialog’s Colors tab and certain plot colors might result in poor contrast. 

� Source File: This property shows the full path name of the graph’s source file if the file was created 
from a file. 

� Data Points: The data points property shows the number of data points in the graph’s data. 

� Min and Max: The minimum and maximum data values are displayed. The values shown here have 
been scaled by the vertical axis Data Offset and Data Scale properties and therefore may not 
correspond to the actual values in the data file. 

� Data Type: The Data Type property displays the format of the data stored in the graph’s source file. 

o Axis Properties: Each axis has its own set of properties that can be viewed and edited from their respective 
tabs in the graph properties dialog. Both axis have similar properties: 

� Axis Scaling: The axis scaling drop-list affects the way values are displayed on the axis for formatting 
purposes only. Changing the axis scaling does not affect the value displayed but only changes the 
format of these numbers. From this list you can choose various engineering scales or the Auto 
selection that automatically chooses the most compact form. The axis scaling property can be used to 
select the engineering units that are best suited to your data. For example, you may prefer to have the 
horizontal axis drawn in millisecond units rather than seconds. 

� Units: The units property is the axis label suffix. This text field is prefixed with the engineering scale 
character in effect. For example, if the units label is ‘W’ and the engineering scale is 10

-3
 the axis label 

will be ‘mW’. 
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� Data Offset (horizontal axis): The data offset horizontal axis property determines the time offset at 
which the first sample occurs. This property is typically set to zero but can be changed to reflect a 
starting time relative to some other graph, for example, when time aligning graphs. 

� Data Offset (vertical axis): The data offset and data scale vertical axis properties together can be used 
to transform the source data so it reflects the physical property being measured. The data offset is 
added to the product of the source data value and the data scale property. The resulting value is the 
actual value plotted on the graph. 

For example, if your data is a signal with a range of values from 0 to 1023 representing a signal voltage 
with a range of ±5 volts, appropriate data offset and data scale values for the vertical axis might be -5 
and 0.009775 (10/1023 approximately)  respectively. 

� Sample Rate (horizontal axis): The graph’s sample rate determines the horizontal axis scale and is also 
used as the default audio playback rate (if possible). The sample rate must be set correctly for the 
spectrum analysis tool and the filtering tools to provide correct results. The sample rate is entered in 
units of samples per second. 

� Data Scale (vertical axis): See the vertical axis data offset description above for how this property is 
used. 

� Font: The font property sets the font used to mark the values along the axis. Clicking the down arrow 
to the right of this property opens a font selection dialog. 

� Tick Size: This property sets the length in pixels of each tick along the axis. 

� Min Tick Space: This property sets the minimum space in pixels between tick marks. 

� Mark Precision: This property sets the number of significant digits each value displayed along the axis 
will have. 

� Tick Color: The color of the axis tick marks can be set by clicking the down arrow button to the right 
of this property. 

� Mark Color: Marks are the ticks associated with the values displayed along the axis. This property 
allows you to change the mark color by clicking the down arrow button to the right of the property. 

� Text Color: This property can be used to set the color of the values displayed along the axis. 

 

Searching for EventsSearching for EventsSearching for EventsSearching for Events    

 You can search for specific events in the signal data using the Find Event tool. An event is a signal 
transition through a certain threshold and remaining on the same side of the threshold for a certain 
minimum time. When you invoke the tool a dialog opens letting you set various search parameters. When 
you accept the dialog parameters the search begins, and if a matching event is found, the marker is placed 
at the event’s location. You can repeat the search with the F3 key and the marker will move to the next 
event if one is found. The following search parameters can be set from the search dialog: 

� Threshold: This parameter is the threshold through which the signal must pass for the event to occur. 
The threshold value is in the same units as the vertical axis. 

� Minimum Duration: This is the minimum amount of time the signal must remain on the same side of 
the threshold after crossing it. The parameter is set in the same units as the horizontal axis. 

� Transition Direction: You can choose whether the event requires the signal to cross the threshold in an 
increasing or decreasing direction for the event to occur. You can also choose to disregard the 
direction in which the threshold is crossed. 
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� Search Range: You can choose to either search the entire graph, search the data selection (if one is set), 
or search a specific range you specify. If you choose to search the entire graph, there is an option to 
begin the search from the current marker location. To search a specific range you specify the start and 
end of the range explicitly. 

 Find Next: The Find Next action can be invoked to find the next event that matches the search criteria. 
The keyboard shortcut for this action is F3. 

EditingEditingEditingEditing    
Many editing actions in DSP Toolbox involve the clipboard. DSP Toolbox maintains a private clipboard for 
graph data, separate from the Windows clipboard. Data in the DSP Toolbox clipboard can be copied and 
pasted between graphs to facilitate working with multiple graphs. Although there is a single clipboard, each 
graph implements its own undo and redo actions independently of each other. 

 Cutting data: The Cut action is available whenever the graph has a selection set. Invoking this action 
copies the selected data to the clipboard and deletes it from the graph. The keyboard shortcut is Ctrl-X. 

 Copying data:  The Copy action is available whenever the graph has a selection set. Invoking this action 
copies the selected data from the graph to the clipboard. The graph’s data is unaffected. The keyboard 
shortcut is Ctrl-C. 

 Pasting data: The Paste action is available whenever the clipboard has data and the graph has a selection 
or marker set. If a selection is set, the clipboard data replaces the selected data. Otherwise if the marker is 
set, the clipboard data is inserted at the marker’s location. The keyboard shortcut is Ctrl-V. 

o Merging data: The Merge action is available whenever the clipboard has data and the graph has a selection 
or marker set.  If a selection is set, the clipboard data is arithmetically summed with the selected data and 
the resulting sum replaces the graph’s data. The length of graph data that is modified is the smaller of the 
selected data length or the clipboard data length. If the graph does not have a selection set and the marker 
is set, then the clipboard data is arithmetically summed with graph data starting at the marker location. 
The length of modified graph data in this case is equal to the length of the clipboard data. The keyboard 
shortcut is Ctrl-Shift-V. 

o Multiplying data: The Multiply action is available whenever the clipboard has data and the graph has a 
selection or marker set.  If a selection is set, the clipboard data is multiplied with the selected data and the 
resulting product replaces the graph’s data. The length of graph data that is modified is the smaller of the 
selected data length or the clipboard data length. If the graph does not have a selection set and the marker 
is set, then the clipboard data is multiplied with graph data starting at the marker location. The length of 
modified graph data in this case is equal to the length of the clipboard data. The keyboard shortcut is Ctrl-
Shift-M. 

 Deleting data: The Delete action is available whenever the graph has a selection set. Invoking this action 
deletes the selected data. The clipboard contents are unaffected. The keyboard shortcut is the Del key. 

 Undoing edits: The Undo action is available whenever edit changes have been made to the graph. You can 
repeatedly invoke this action to undo the next change in reverse order in which they were applied. The 
keyboard shortcut is Ctrl-Z. 

 Redoing edits: The Redo action is available whenever one ore more Undo actions have been applied. You 
can redo undo actions back to the point where an intervening edit was applied. The keyboard shortcut is 
Ctrl-Y. 

 Scaling data: The Scale Graph Data action can be invoked at any time. If a data selection is set, scaling is 
applied to the selected data, otherwise scaling is applied to the entire graph. When you invoke this action a 
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small dialog appears prompting for the scale factor. This action is available from the data toolbar and the 
Tools menu. 

FilteringFilteringFilteringFiltering    
DSP Toolbox’s FIR filter tool lets you filter graph data with any arbitrary FIR filter. The FIR filter coefficients 
defining the filter can be synthesized with DSP Toolbox’s filter design tool or imported externally. You use the 
FIR filter coefficient import and editor tool to set the filter coefficients. The coefficients will be retained for the 
next time you use the filter tool, but you can change the filter coefficients any time. 

 Setting or editing the FIR filter coefficients: To set new filter coefficients for the FIR filter tool, invoke the 
Set or Edit FIR Filter action from the data toolbar or the Tools menu. This will open the FIR filter 
coefficient editor from where you can set the coefficients in any of the following ways: 

� Load from Designer: Click this button if you have previously run the filter design tool and designed a 
filter. The coefficients from the filter designer will be copied to the filter coefficient editor. 

� Load from File: Click this button to import the filter coefficients from a text file. 

� Paste from the clipboard: If you copied filter coefficients to the Windows clipboard you can simply 
click in the filter editor’s coefficient list and type Ctrl-V to paste the coefficients into the coefficient 
editor. If you need to clear existing coefficients from the editor, click the Clear button on the top right 
of the editor. 

� Manually enter coefficients: You can enter the coefficients manually by typing them into the editor’s 
coefficient list. 

 Filtering graph data: You can apply a FIR filter to a graph’s data with the Apply FIR Filter tool. The filter is 
applied to the data selection if one is set; otherwise the entire graph is filtered. The filter’s coefficients are 
set using the FIR filter import and edit tool, as described above. If no coefficients have previously been set 
the coefficient import and editor tool will appear when you invoke the Apply FIR Filter tool. This tool is 
available from the data toolbar or the Tools menu. 

 Viewing the filter response: If FIR filter coefficients have been set, you can view the resulting filter’s 
frequency domain response by invoking the Show Filter Response action. When you invoke this action a 
floating window opens showing the frequency domain response of the filter. You can set the sample rate at 
which the filter response is determined by clicking the Sample Rate button on the right end of the floating 
window’s toolbar and entering a new value. 

Playing AudioPlaying AudioPlaying AudioPlaying Audio    
The audio playback tool lets you listen to signal data as audio through your computer’s sound system. When 
you open a graph the audio sample rate is set to the graph’s sample rate, but you can independently set the 
audio playback sample rate to any value supported by your computer’s sound system. 

 Starting and stopping audio playback: Clicking this button on the graph toolbar starts and stops audio 
playback. The section of audio played is determined by the marker and data selection: 

� If neither a marker or data selection exists the entire graph is played. 

� If data is selected and the marker is not set the selected section is played. 

� If the marker is set but no data is selected audio is played from the marker location to the end of the 
graph. This also applies if the marker is past the end of a data selection. 

� If data is selected and the marker is located before the end of the selection, audio is played from the 
marker location to the end of the selection. 
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The marker advances through the graph as playback proceeds, providing visual feedback of the playback 
progress. You can stop playback at any time by clicking the toolbar button again. If you restart playback, it 
will begin from where the marker was last set. 

 Setting the audio playback sample rate: Clicking this button shows a drop-list of sample rates to choose 
from and a text box where you can enter any arbitrary sample rate. The availability of any particular audio 
playback sample rate is dependent on your computer’s sound system and not all sample rates may be 
available. If you choose a sample rate that is not available on your computer a message informing you of 
this will appear when you attempt playback with that sample rate. 

To simplify entering sample rates in the text box, if you enter a sample rate less than 200 Hz it will be 
automatically converted to a value specified in KHz. For example, if you enter 44.1 in the sample rate text 
box the sample rate will be set to 44.1 KHz but if you enter 8000 the sample rate will be set to 8 KHz. 
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    Working wWorking wWorking wWorking with Multiple Graphsith Multiple Graphsith Multiple Graphsith Multiple Graphs    

DSP Toolbox is a multi-graph workspace environment that lets you view and work with multiple graphs 
simultaneously. This section provides details on the actions you can apply to multiple graphs and how to align 
graphs. 

MultiMultiMultiMulti----Graph Selection and EditingGraph Selection and EditingGraph Selection and EditingGraph Selection and Editing    
Certain DSP Toolbox actions can be applied to multiple graphs at one time. To select more than one graph do 
one of the following: 

� Ctrl-click a graph’s left border to toggle its selection state 

� Select one graph by clicking its left border then Shift-click another graph to select all graphs between 
and including the graphs you clicked 

� Type Ctrl-Shift-A to select all graphs 

To unselect all graphs but one, simply click a graph’s left border. 

The following actions can be applied to multiple graphs: 

 Close graph  Refresh graph 

 Set graph color  Auto-range 

 Increase range  Decrease range 

 Increase zoom  Decrease zoom 

 Set zoom  Align by time 

 Align by markers  Remove from alignment group 

 Spectrum analysis  Scale data 

 Filter data  

 

GraphGraphGraphGraph Alignment Alignment Alignment Alignment    
You can horizontally align two or more graphs to view them with the horizontal axes time aligned. You can 
also align two or more graphs so the location of their markers is aligned. When a graph is part of an alignment 
group a link icon will appear in its left border. The alignment actions are available from the data toolbar or the 
Tools menu. 

 To align graphs by time, first adjust the horizontal axis data offset properties of each graph so the 
horizontal axis of each graph starts at the time you want it to appear relative to the other graphs. The data 
offset property is set in the graph properties dialog. Next, select the graphs you want to align and invoke 
the Align Graph Data action. The graphs will be time aligned automatically. 

 To align graphs by their markers, you first set a marker in each graph at the location you want it to be 
aligned with the other graphs. Next, you select the group of graphs you want to select and invoke the Align 

Markers action. All the graphs in the group will be shifted so their makers are aligned. 

 To remove one or more graphs from the alignment group, select the graphs you want to remove from the 
group and invoke the Remove From Alignment Group action. 
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    The The The The Signal GeneratorSignal GeneratorSignal GeneratorSignal Generator Tool Tool Tool Tool    

 DSP Toolbox’s signal generator tool can be used to synthesize a variety of common signals. More complex 
signals can be created by either summing or multiplying two signals. The signal generator tool can synthesize 
sine, triangle, pulse, noise and constant (DC) signals. 

Placing Generated SignalsPlacing Generated SignalsPlacing Generated SignalsPlacing Generated Signals    
The generated signal is placed into a graph either by inserting a new section of graph data or by replacing an 
existing section. Insertion is used whenever the marker is set but no selection exists. If a graph selection is set 
then data replacement is used instead. When a selection is set the replacement method is used and the 
selected graph data, or a section of it, will be overwritten with new data. When replacing data you can choose 
one of three replacement modes which you select from the signal generator’s Merge Mode drop down list box: 

� Replace: Selecting replace mode causes the selected graph data to be substituted for the generated 
signal data. The selected data is always completely removed regardless of the duration of the generated 
signal and the entire generated signal is placed into the graph. This behavior is similar to the Paste 
action. 

� Sum: In sum mode the duration of replaced graph data is either the duration of the selected data or 
the duration of the generated signal, whichever is less. The selected graph data is replaced with the 
sum of the generated signal and the selected graph data, up to the lesser duration of the two. 

� Multiply: In multiply mode the duration of replaced graph data is either the duration of the selected 
data or the duration of the generated signal, whichever is less. The selected graph data is replaced with 
the product of the generated signal and the selected graph data, up to the lesser duration of the two. 

The signal generator tool has a Duration textbox that determines the length of the generated signal. The units 
in which this value is entered matches the horizontal axis of the selected graph and appears to the right of the 
duration textbox. If a selection is present in the graph the duration will be preset to the selection length, 
otherwise no value will be initially set. You can change the generated signal duration to any value you desire, 
however if data is selected in the graph the maximum duration is the selection duration. 

All synthesized signals have an offset parameter which you can set. The offset parameter is a fixed value about 
which the synthesized signal is centered on the vertical axis. The units in which this value is entered matches 
the vertical axis of the selected graph and appears to the right of the Offset textbox. Most signal types also have 
an amplitude parameter which will be in the same units as the offset parameter. The amplitude parameter 
specifies the peak-to-peak signal amplitude. 

Generated Signal TypesGenerated Signal TypesGenerated Signal TypesGenerated Signal Types    
The signal generator tool can synthesize sine, triangle and pulse waveforms in addition to white noise and 
constant (DC) signals. The Signal Type drop down list box selects the desired signal type. For each signal type 
the amplitude parameter specifies the peak to peak amplitude of the generated signal. Each of these signal 
types is described below: 

� Constant: This selection produces a constant value. This signal type has only a single parameter, the 
offset, which determines the constant value to be generated. 

� Sine: The sine selection generates a sinusoidal waveform. In addition to the offset and amplitude 
parameters, the sine signal type also has frequency and phase parameters that you can set. The 
frequency parameter is in units of Hz and can range from zero to one half the graph’s sample rate. The 
phase parameter controls the initial starting point for the signal and has a range of zero degrees to 360 
degrees. A zero phase setting corresponds to a sine waveform starting at the offset level and rising. 

� Triangle: The triangle waveform produces an up and down ramp signal. The frequency parameter is in 
units of Hz and can range from zero to one half the graph’s sample rate. The Duty Cycle parameter 
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controls the relative slopes of the rising and falling segments. When the duty cycle is 50% the resulting 
waveform has rising and falling slopes that are equal but opposite. The duty cycle parameter can range 
from 0% to 100%. The Phase parameter controls the starting point for the generated signal and can 
range from zero degrees to 360 degrees. A zero phase setting corresponds to a starting point at the 
lower amplitude limit and rising. 

� Pulse: The pulse signal type produces a binary level pulse signal with a specified duty cycle. The 
frequency parameter is in units of Hz and can range from zero to one half the graph’s sample rate. The 
ratio of the high level duration to the low level duration is controlled by the Duty Cycle parameter 
which can range from zero to 100%. The phase parameter can range from zero degrees to 360 degrees 
and controls the starting point for the signal. A zero phase setting corresponds to a starting point at a 
rising pulse edge. 

� Noise: The noise signal type generates a white noise signal at the specified amplitude. 

� Random bits: The random bits signal type generates a random sequence of binary values at a specified 
bit rate. The frequency parameter, which specifies the bit rate in bits per second, is in units of Hz and 
can range from zero to one half the graph’s sample rate. 
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    The Filter Design ToolThe Filter Design ToolThe Filter Design ToolThe Filter Design Tool    

 DSP Toolbox’s filter design tool is a complete FIR filter design solution based on the Parks and McClellan 
synthesis algorithm. The filter designer finds the FIR filter coefficients for any low pass, high pass, band pass, 
band stop or multi-band FIR filter. Filter length and complexity is unlimited. The filter design tool can be 
opened from either the data toolbar or the Tools menu. 

 

 

 

Getting Started with the Filter DesignerGetting Started with the Filter DesignerGetting Started with the Filter DesignerGetting Started with the Filter Designer    
The filter design tool opens in a floating window separate from DSP Toolbox’s main window. You choose the 
filter parameters from the dialog in the top section of the window and then click the Design button to generate 
the filter coefficients and display the response graphs in the bottom section of the window. The simplified 
graph toolbar above the graphs provides many of the same graph actions available in DSP Toolbox’s main 
window. There are a set of general filter parameters that apply for all filter types and others that are specific to 
the type of filter you choose. When you select a filter type the dialog changes and displays parameters specific 
to the filter type. The filter’s range of operation extends from zero Hz to one half the sample rate frequency. 

After the filter design completes, the frequency response graph is displayed in the graph section of the window. 
You can also display the filter’s impulse and phase responses by checking these options in the Graphs section 
of the dialog. The filter’s frequency response is plotted with a log dB scale on the vertical axis. You can 
manually set the dB base line for the vertical axis, or by checking the Auto option the designer will 
automatically choose an appropriate base line approximately 20 dB below the stop band attenuation. 
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Filter Filter Filter Filter Parameters by Filter TypeParameters by Filter TypeParameters by Filter TypeParameters by Filter Type    
The filter examples below show the parameters that are specific to each filter type. For clarity the transition 
widths are not shown for the multi-band filter. 
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Filter ParametersFilter ParametersFilter ParametersFilter Parameters    
Following are detailed descriptions for all filter parameters: 

� Filter Type: From this drop-list you choose the type of filter you want to design. You can choose from: low 
pass, high pass, band pass, band stop and multi-band. Selecting multi-band lets you design any arbitrary 
filter with multiple pass and stop bands. 

� Frequency Units: This drop-list lets you choose the frequency scale you want to work in. You can choose 
Hz, KHz, MHz or GHz. This selection determines the frequency units of the sample rate, band frequency, 
and transition width parameters. 

� Sample Rate: You enter the sample rate for the design here in the frequency units you selected. For 
example, if you want to design for an 8 KHz sample rate and you selected KHz in the Frequency Units 
drop-list, you would enter 8 here. 

� Filter Length: The filter length is the number of coefficients the filter designer will produce and determines 
the filter complexity. Usually you want to choose the smallest filter length that produces a filter meeting 
your design requirements. In general, filter lengths increase as filter requirements become more stringent. 
It is recommended that you initially use the Estimate Length button to set the filter length and increase or 
decrease the length as appropriate based on the resulting performance and your requirements. The filter 
designer will create the best possible filter for the given filter length, however the resulting filter may not 
meet all performance criteria if its length is too short.  The filter designer may not be able to synthesize a 
filter if you specify a filter length that is much longer than required. 

Filters with a final pass band at the high frequency end should be specified with an odd length otherwise 
the filter will have poor performance. This applies to high pass, band stop and multi-band filters which end 
in a pass band. 

� Pass Band End (low pass filters): This frequency specifies the point at which the filter attenuates higher 
frequency signals. This value plus the transition width must be less than one half the sample rate. 

� Pass Band Start (high pass filters): This frequency specifies the point at which the filter attenuates lower 
frequency signals. This value must be less than one half the sample rate and greater than the transition 
width. 

� Band Pass Center (band pass filters): This is the center of the pass band frequency range. 

� Pass Band Width (band pass filters): This is the difference between the lowest and highest frequencies 
which the filter passes unattenuated. The pass band, including the transition widths on either side, must 
not extend to zero Hz and must be below one half the sample rate. 

� Stop Band Center (Stop band filters): This is the center of the stop band frequency range. 

� Stop Band Width (Stop band filters): This is the difference between the lowest and highest frequencies the 
filter attenuates by at least the specified stop band attenuation. The stop band, including the transition 
widths on either side, must not extend to zero Hz and must be below one half the sample rate. 

� Transition Frequencies (Multi-band filters): Multi-band filters are specified as a sequence of alternating 
pass and stop bands. The first band (starting at zero Hz) will be a stop band if the First Band is Stop Band 
checkbox is checked. You enter the ending frequency of each band except the final band, which always ends 
at one half the sample rate. For a pass band this is the frequency where the attenuation starts to increase 
towards the stop band attenuation. For a stop band this is the frequency at which the attenuation starts to 
decrease towards zero. The highest transition frequency plus the transition width must be less than one half 
the sample rate. 

� First Band is Stop Band checkbox (Multi-band filters): This checkbox determines whether the first band of 
a multi-band filter is a stop or pass band. 
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� Transition Width: Filters consist of alternating pass bands and stop bands. The transition width is the 
difference in frequency between the end of one band and the start of the next. For example, a low pass 
filter’s transition width is defined as the difference in frequency between the pass band end and the lowest 
frequency at which the filter achieves its designed stop band attenuation. For filters with more than two 
bands, the transition width parameter applies to all band transitions. The filter designer uses this parameter 
to determine the maximum allowed transition width but the resulting filter might have transitions that 
exceed this specification if the filter length is too short. 

� Pass Band Ripple: Enter here in dB the maximum peak-to-peak ripple in the pass bands. If the filter 
designer produces a filter with pass band ripple greater than this vale the filter length may be too short. 

� Stop Band Attenuation: Enter here in dB the minimum attenuation in the stop bands. This is a positive 
number that increases with greater attenuation. If the filter designer produces a filter with stop band 
attenuation less than this value the filter length may be too short. 

� Estimate Length button: Click this button to automatically set the filter length to an estimated value for the 
design you specified. This is the recommended method to set your initial filter length. The button is 
enabled when all other parameters are set. The estimate is based on the specified transition width and stop 
band attenuation. If you need a filter with an exceptionally flat pass band you may have to increase the filter 
length above the estimate in order to meet all the requirements. 

ExportingExportingExportingExporting and Using and Using and Using and Using FIR Filter Coefficients FIR Filter Coefficients FIR Filter Coefficients FIR Filter Coefficients    
After the filter designer completes a design the filter coefficients can be loaded into the FIR filter coefficient 
editor. To use the filter designer’s coefficients with the Apply Filter action you first open the filter coefficient 
editor and click the Load from Designer button; the designer’s filter is now ready to be applied to graph data. 
See the Filtering topic of the Working with Graphs section for more information on the coefficient editor and 
filtering graph data. 

You can copy the filter coefficients to the Windows clipboard by clicking the Copy Coefficients button in the 
filter design tool. You can also export the coefficients to a text file with the File->Save Filter Coefficients menu 
selection in the filter designer’s window. 
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    The Spectrum Analysis ToolThe Spectrum Analysis ToolThe Spectrum Analysis ToolThe Spectrum Analysis Tool    
 The spectrum analysis tool performs an FFT transform on a section of a graph’s data and displays the 

frequency domain power spectrum of the signal. If a data selection exists in the graph the selection’s data is 
analyzed, otherwise the entire graph is analyzed. By default the spectrum is displayed in a floating window 
separate from DSP Toolbox’s main window but you can choose to have spectrum analysis graphs appear in the 
main window instead. This option is set from the Spectrum Analysis tab of the options dialog. 

There are three parameters you can set that affect how the spectrum analysis tool analyzes the data and 
presents its results: 

� Sample rate: You can choose a sample rate for spectrum analysis independently of the graph’s sample 
rate. 

� FFT windowing function: You can choose one of several windowing functions to shape the data section’s 
envelope. Different widowing functions affect the frequency selectivity and spurious response 
characteristics of the resulting spectrum. The available windowing functions are: 

 

Rectangle Bartlett 

Blackman Flat Top 

Gaussian Hamming 

Hann Tukey 

 

� Log scale: You can choose either a dB log scale or a linear scale for the spectrum’s vertical axis. If you 
choose a dB log scale the settings from the Log Scale tab of the program options will determine the log 
scale parameters. See the Log Scale Options topic of The Options Dialog section for more information. 

By default you will be prompted for these choices each time you invoke the spectrum analysis tool but you can 
choose to always use the same settings and not be prompted. You can change the spectrum analysis tool’s 
default behavior from the Spectrum Analysis tab of the options dialog. 
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    The Print and Print Preview DialogsThe Print and Print Preview DialogsThe Print and Print Preview DialogsThe Print and Print Preview Dialogs    
DSP Toolbox provides extensive print and print preview options to let you print your graphs with a degree of 
flexibility. This section provides information on setting up the print parameters, previewing the pages to be 
printed and printing. 

    Page SetupPage SetupPage SetupPage Setup    
The page setup dialog is opened from the File->Page Setup menu selection. This is a standard page setup 
dialog that sets up the physical page properties. From here you choose page size, orientation and margins. 

    Print PreviewPrint PreviewPrint PreviewPrint Preview    
You can preview how graphs are printed and interactively change print options from the print preview dialog. 
The dialog lets you navigate the preview pages, select the graph properties and views to print, and control page 
layout. 

 

 

 

Navigating and Navigating and Navigating and Navigating and AdjustingAdjustingAdjustingAdjusting the Page Preview the Page Preview the Page Preview the Page Preview    
A preview of the printed pages appears in the bottom section of the print preview dialog. The view adjusts 
automatically as the dialog window is resized. The page view toolbar along the top of the dialog has the 
following buttons and controls: 

 Print: Clicking this button opens the print dialog from where you can initiate printing the graphs as you 
see them in the print preview window. 
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 Page setup: Clicking this button opens the page setup dialog. 

o Page navigation control:  The page navigation control lets you navigate forward or backward through the 
preview pages. The single arrow buttons step in increments of one page and the double arrows step 
through one page group at a time. You can directly enter a page number to go to in the page number box. 

 Page view zoom: Clicking this button shows a drop-list of zoom selections for the preview. The Auto 
selection causes the view to fill the window’s available space while displaying entire pages or an entire page 
group. 

 Single page view: This button selects the single page preview mode. 

 Two page view: This button selects the two page preview mode. It is available whenever the preview has 
more than one page. 

 Four page view: This button selects the four page preview mode. It is available whenever the preview has 
three or more pages. 

 Six page view: This button selects the six page preview mode. It is available whenever the preview has five 
or more pages. 

Graph PrintGraph PrintGraph PrintGraph Printinginginging Options Options Options Options    
Following are the graph print options available from both the print and print preview dialogs: 

� Which graphs to print: In the Graphs section of the preview dialog or the Print Range section of the 
print dialog you can choose to print either all graphs or just the selected graphs. 

� Which graph section to print: In the Graph View section of the print preview dialog or the Print Range 
section of the print dialog you can choose to print entire graphs, the graphs in their current (possibly 
zoomed) view, or the just the data selection, if one is set. 

� Graph features to print: You can show or hide data selections and markers. 

ManagingManagingManagingManaging Page Layout Page Layout Page Layout Page Layout    
Both the print preview and print dialogs have controls to adjust the page layout: the Vertical Zoom slider, the 
One per Page checkbox and the Fill Page checkbox. Both dialogs display the number of pages to be printed 
with the current page layout settings. 

The Fill Page checkbox option causes the graphs to be automatically zoomed vertically to fill each printed 
page. When this option is checked graphs will be zoomed at least the amount set by the zoom slider but more 
if needed to fill the page. If the Fill Page option is not checked, the vertical zoom slider operates in a linear 
fashion, and additional pages are created as needed. With the Fill Page option checked, the zoom slider only 
affects the number of pages. 

The One per Page checkbox option causes a single graph to be printed on each page. If both this and the Fill 

Page options are checked the vertical zoom has no effect and the zoom slider is disabled. 

    PrintingPrintingPrintingPrinting    
Printing is started from the print dialog, which you can open from either the File menu or with the Print 
button on the print preview dialog toolbar. The print dialog has all the same graph print and page layout 
options available in the print preview dialog but does not show page previews. From the main window, you can 
use the Ctrl-P shortcut to open the print dialog. 
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    The Options DialogThe Options DialogThe Options DialogThe Options Dialog    
DSP Toolbox options can be set from the program options dialog, which you open from the Tools menu. The 
dialog has four tabs: Graphs, Colors, Spectrum Analysis and Log Scale. You can reset all options to their default 
state by clicking the Restore Defaults button at the bottom right of the dialog. 

Graph OptionsGraph OptionsGraph OptionsGraph Options    
The Graphs tab has options for warnings and default values: 

� Warn before closing graphs with unsaved changes: If this option is checked a dialog box will ask for 
confirmation before closing graphs with unsaved changes. 

� Warn before deleting graph data: If this option is checked a dialog box will ask for confirmation before 
performing actions that delete graph data. 

� Default sample rate: This is the default sample rate that is set when opening files that do not contain 
sample rate information. You can change the sample rate of any graph by setting its horizontal axis 
sample rate property. See the About Sample Rates and Time Scales topic of the Importing Signal Data 
section for more information. 

� Default graph height: This value is the height in pixels of new graphs when they are opened. See The 

Graph Window and Resizing Graphs topics of the Working with Graphs section for information on how 
to change graph heights. 

� Zoom step size: This is the multiplier used when the graph zoom is stepped. For example, if the zoom 
step size is 2, the zoom will step up from 1 to 2, 4, 8, 16 etc. with each step. The reciprocal of this value is 
the multiplier used when stepping down the zoom. 

� Range step size: This is the multiplier used when the graph vertical range is stepped. For example, if the 
range step size is 2, the vertical range will step up from 1 to 2, 4, 8, 16 etc. with each step. The reciprocal 
of this value is the multiplier used when stepping down the range. 

� Apply zoom to all graphs: If this option is checked zoom actions will be applied to all graphs regardless 
of selection and all graphs will have the same zoom factor at all times. If this option is unchecked each 
graph’s zoom setting will be independent and zoom actions are applied to selected graphs only. 

Color OptionsColor OptionsColor OptionsColor Options    
The Colors tab contains default color selections for various graph elements. You can click the down arrow 
button to the right of any color setting to change the color. The plot color of any graph can be changed with 
the Set Graph Color action available on the graph toolbar, the Graph menu or the graph properties dialog. 
Additional color customization is available from the graph properties dialog. 

� Data graph plot color: This is the default color used to plot ordinary data graphs you open from a file. 

� Spectrum graph plot color: This is the default color used to plot spectrum analysis graphs. 

� Filter graph plot color: This is the color used to plot filter response graphs. 

� Selection foreground color: This is the color of the plot for selected data sections. 

� Selection background color: This is the color of graph’s background for selected data sections. 

� Vertical range line color: This is the color used to draw the vertical range lines. 

� Vertical range info color: This is the background color of the range panel that appears when a vertical 
range is selected. 
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Spectrum Analysis OptionsSpectrum Analysis OptionsSpectrum Analysis OptionsSpectrum Analysis Options    
The options in this tab are the default spectrum analysis options. If you select Ask for FFT Options in this tab 
page you will be prompted each time you invoke the spectrum analysis action for the FFT options. See The 

Spectrum Analysis Tool section for a description of each spectrum analysis option. 

Log Scale OptionsLog Scale OptionsLog Scale OptionsLog Scale Options    
The log scale options apply to spectrum analysis graphs when you choose a dB log scale for the vertical axis. 
The log scale has two options: 

� Zero dB reference level: You select the zero dB level with this option. You can choose to use the 
minimum or maximum data values in the graph as the zero dB reference or you can choose any arbitrary 
level explicitly. If you choose minimum data level the smallest non-zero data value is used as the 
reference. 

� Log multiplier: This the scalar multiplier used to scale the data after taking its logarithm. 
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    Keyboard ShortcutsKeyboard ShortcutsKeyboard ShortcutsKeyboard Shortcuts    
    
Keys Actions 
Ctrl-N Open a new empty graph 

Ctrl-O Open graph from file 

Ctrl-S Save selected graphs 

Ctrl-Shift-A Select all graphs 

Ctrl-1 Set all graphs to zoom 1 

Ctrl-W Set vertical size of all graphs to fit view 

Down arrow Set selected graph to next graph 

Up arrow Set selected graph to previous graph 

Left arrow Scroll left 

Right arrow Scroll right 

Home Scroll to left extreme 

End Scroll to right extreme 

Ctrl-G Go to marker 

Ctrl-C Copy selected data 

Ctrl-X Cut selected data 

Ctrl-V Paste data 

Ctrl-Shift-V Merge (add) clipboard data 

Ctrl-Shift-M Multiply clipboard data 

Ctrl-A Select all data 

Del Delete selected data 

Esc Clear graph data selection 

Ctrl-Z Undo edit 

Ctrl-Y Redo edit 

Plus key (+) Increase zoom 

Minus key (-) Decrease zoom 

Ctrl-M Zoom about marker 

F9 Zoom data selection 

Ctrl-R Auto-range 

Ctrl-+ (Ctrl and plus key) Increase vertical range 

Ctrl-- (Ctrl and minus key) Decrease vertical range 

Ctrl-F Find event 

F3 Find next event 

F2 Open graph properties dialog 

F5 Refresh from file 

Ctrl-P Open print dialog 

Mouse scroll wheel Scroll vertically 

Shift with mouse scroll wheel Scroll horizontally 

 


